Baby Name News articles not loading properly

Anyone else having trouble with this? I’ve tried on my home and mobile connection and there’s no problem loading other sites so it’s not an Internet problem. They are loading but very slowly (like 3 minutes per article).


This has been happening to me too. Sometimes the articles won’t even load at all.


I’ve had the issues of them not loading at all, whether I access it from an email or directly from the website. All I get is a white screen.

same here. most articles don’t load at all for me!

@standardcrow @Gia.berry @the_common_fool @planetnames

What browser are you all using?

Are you running any add-ons (e.g. adblocker)?

Have you tried in private browsing mode, and does the problem still happen there?


I’ve done it on a school-issued laptop with an ad blocker, then tried it on my phone (no ad blocker) both in private mode and without. The issue still persisted.

1 Like

OK, thanks for the info! Which browser are you using?

Also, is it all blog posts or just recent ones? Could you please test a couple of links?


1 Like

I’ve tried private browsing, and no adblocker. On [name_u]Safari[/name_u] it doesn’t work for me, but I just tried Google Chrome and it works there!

It’s working fine for me.

The first one isn’t loading for me but the second one works fine!

1 Like

Safari on an iPad. Problem has just been the last two days.

1 Like

First link doesn’t work. Second link loaded a bit slower than average but not stupidly slow

1 Like

OK, let me post a few more links to test below…

one & two — Title & photo load fine but text doesn’t (white space)
three & four — Load fine for me

(on safari, other browsers seem to work)


Thanks. This is what I’m seeing too. We will look into what’s going on!

1 Like


1 Like

Sorry, I forgot to mention my browser is Chrome!

Of the first test links: first one didn’t load, second worked fine.

For the second group of test links: all loaded for me!

1 Like

Safari on laptop – older blog posts work completely fine, whereas the newer ones won’t load and cause the site to freeze or crash.

Google on phone – haven’t tested older blog posts but the newer ones take longer to load (they do eventually load though and don’t cause crashing/freezing).

1 Like

Hi everyone, this appears to be related to the name links in blog posts, which have now been temporarily disabled.

Hopefully you’ll be able to access these blogs now (please let me know!) and we will work on adding the name linking back without causing issues.


It’s working for me now! Thank you :slight_smile:

1 Like