Poll results displaying as NaN%

I’ve never seen this before so I’m incredibly confused. Has anyone else experienced this?

Apparently all of my polls say it:

They work for me.

@winterara

They are displaying normally for me too. [name_f]Do[/name_f] you see the same for polls created by other users, or just yours?

Have you checked any other polls not in this thread?

@katinka It looks normal on polls created by other users in the same thread, and in a different thread.

Do you remember if you edited the polls after creation?

@katinka I don’t believe I did.

OK, let me try and see if I get the same results. Please vote on my poll! :slight_smile:

Your favourite colour(s)?
  • Blue
  • Green
  • Red
  • Yellow
  • Orange
  • Purple

0 voters

1 Like

Hmm @winterara I am able to see the percentages as normal. I’ve also tried editing the post to see if that made a difference and it didn’t.

What about this poll?

Still the same NaN thing :woman_shrugging:

OK, thanks for bearing with me and answering all my questions!

We updated Discourse to the latest version earlier today and my suspicion is that there are a few issues with this release, which don’t have anything to do with this site. It’s not related to the main Nameberry update, as the forums run on a completely different site and platform.

Generally, bugs following new releases are fixed pretty quickly so I will keep an eye on the Discourse main site for more info.

1 Like

Of course! Thank you all for your dedication!!

1 Like

Just edited the title to be clear in case anyone else is having this problem :slight_smile:

1 Like

It might be a problem with the part of the code that displays the values? NaN usually stands for ‘Not a Number’ in languages like python.

2 Likes

Interesting! You’re probably right. This code will be with Discourse itself rather than Nameberry so let’s hope they catch it and update soon.

1 Like

I am also having the same problem. Started at the same time and still not working!

What browser / device are you both using?

I’ve tried on all my devices! On my chromebook, iphone, and ipad.

I’m guessing it only happens if you only allow people to see the results after they voted. I don’t think I ever got the NaN% thing but a few months ago, I noticed I wasn’t able to see everything in the results (I don’t remember is it was percentages or maybe I couldn’t see who voted) when I had the poll results set to “On vote” even after I press “Show vote” on the bottom. The only way I was able to get around it is if I voted in my own poll so I have since only used “Always visible” instead of the “On vote” Results setting

1 Like

@name_sage did just inform me that it worked for her on The Quick [name_u]Poll[/name_u] Thread by doing this!

1 Like

Cool, glad it’s somewhat working!

@katinka
Btw, I found my old post where I mentioned the issue I was talking about since it sounds like it could be related to a similar problem I had back in July. I don’t know if this problem actually ever got fixed since I just stopped using the “on vote” setting

2 Likes