Linking Names & Tagging People

I’ve been having trouble lately with a couple of different things.

First, when the links for names show up, not all of them are “active”. When you go into to edit them, the links are there, but they don’t show on the post. I have to go through and add a character, hit save for the links to activate on the post, edit again removing the character and hit save again for the links to show without odd characters. Most of the time I notice it is the first name in a paragraph, especially if it is the first word of that paragraph.

The other thing is tagging someone. I’ll start typing @name, and potential names will show up. I’ll click on the name I’m looking for, and it will leave me with the partial name I typed, but won’t fill in the rest of it. I don’t always notice it until I hit the save button.

5 Likes

I don’t seem to have the tagging problem but I’ve noticed the missing links & I’ve also been using the method of “edit + add a character, edit again + remove the character” to get them to show up. It usually happens when the name is at the beginning of a paragraph or in a list.

2 Likes

I’ve been having this problem too! Usually it helps if I don’t click on the suggestions as they pop up and instead type out the full username. I also always check before I post to make sure all the tags are working!

2 Likes

I’ve started typing it out fully, but it still shouldn’t work this way. It’s one of those bugs that will need to be worked out when they get a chance. Unfortunately, if it’s not mentioned, it’s harder to pinpoint that there’s an issue.

1 Like

I didn’t notice the issue with linking names, but tagging issue is very annoying.

2 Likes

I’m aware of the missing links issue and sent a list of instances where this happens (first word in a paragraph, after a slash, etc.) to the tech team ages ago. I will give it a bump.

I know it’s a bit annoying, but I tend to just leave the missing links. There’s no need to go back in and add a character to get them all to show up — unless you particularly want to, of course!

As for the tagging issue, I’ve noticed a few hiccups with that too. I’ll have a play around with it today and try to pinpoint what’s going wrong.

To be honest, I doubt the tagging will be something that’s within our power to fix; it seems more likely to be a Discourse issue, which may well be addressed in future versions.

2 Likes

Thank you!

@katinka I’m not sure where to post this, so I thought I would just put it on this thread. I just found an accented name I wanted to look up, Zélie. When you try to link it, and then click on said link, it takes you to the NB database page that lists all possible blog topics that could possibly relate to it. On the other hand, if you run through and use the advanced search feature on the NB homepage, it will list accented names without links. I was only able to access the page for Zélie when I ran a Google search and it took me straight to the name page. Is there any way to correct this?

1 Like

This is a common problem with names containing diacritic marks, as I recall. I think the issue is that the accented letters are generally in caps in the name page URLs (I don’t know why, it may be that it has to be like this).

Here are some examples:

https://nameberry.com/babyname/ZÉlie

https://nameberry.com/babyname/EsmÉe

https://nameberry.com/babyname/ChloË

https://nameberry.com/babyname/AnaÏs

https://nameberry.com/babyname/MarÍa

https://nameberry.com/babyname/FranÇois

That last one doesn’t even link on Nameberry, I had to go in through Google. In fact, no names containing ç, ñ or à link internally, by the looks of it.

Here is a search for names containing Ç; notice none of them are live links :point_down:

@pam is this something that’s already known about?

1 Like

Is it due to how it has to be written on the address bar as opposed to on the page itself?